# RSP DALQueryError

**URL:** <https://www.rubin.community/t/rsp-dalqueryerror/11578>\
**Category:** Rubin Science Platform\
**Tags:** dp1\
**Created:** [February 10, 2026, 1:33pm UTC](https://www.rubin.community/t/rsp-dalqueryerror/11578 "2026-02-10T13:33:57Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![jrob93](https://sea2.discourse-cdn.com/flex002/user_avatar/www.rubin.community/jrob93/32/4102_2.png) [@jrob93](https://www.rubin.community/u/jrob93)\
**Post date:** [February 10, 2026, 1:33pm UTC](https://www.rubin.community/t/rsp-dalqueryerror/11578/1 "2026-02-10T13:33:57Z")

</div>

Hi I’m trying to run some queries on dp1 and I’m getting the error:

```auto
DALQueryError: Query Error: Query failed in backend: MERGE_ERROR 2010 (failed to open[/read](https://jrob.nb.data.lsst.cloud/read): http://sdfqserv002.sdf.slac.stanford.edu:44685/6-5771126-0-78967-0.csv, fileSize: 1027353, offset: 0, ex: error: 'Couldn't resolve host name', errnum: 6) 2026-02-10T13:29:01+0000

```

I noticed this just now whilst trying to rerun queries that were working earlier today. I also tried a tutorial notebook (201.4) and the same error crops up. I presume there’s an issue with the RSP?

---

<div class="post-metadata">

**Author:** ![MelissaGraham](https://sea2.discourse-cdn.com/flex002/user_avatar/www.rubin.community/melissagraham/32/2549_2.png) [@MelissaGraham](https://www.rubin.community/u/MelissaGraham)\
**Post date:** [February 10, 2026, 5:09pm UTC](https://www.rubin.community/t/rsp-dalqueryerror/11578/2 "2026-02-10T17:09:45Z")

</div>

Hi James, thanks for reporting this. I can confirm I get the same error message and also that there was an issue with Qserv (TAP backend) last night, and it looks like it’s not resolved yet. We’ll make sure the fix gets reported back here as soon as we confirm the TAP service is restored.

---

<div class="post-metadata">

**Author:** ![MelissaGraham](https://sea2.discourse-cdn.com/flex002/user_avatar/www.rubin.community/melissagraham/32/2549_2.png) [@MelissaGraham](https://www.rubin.community/u/MelissaGraham)\
**Post date:** [February 10, 2026, 7:06pm UTC](https://www.rubin.community/t/rsp-dalqueryerror/11578/3 "2026-02-10T19:06:57Z")

</div>

TAP service has been restored. I confirmed it with a simple query on the DP1 object table, and am marking this topic as solved. But as always, please open new Support topics for new issues anytime, thanks!

---

<div class="post-metadata">

**Author:** ![jrob93](https://sea2.discourse-cdn.com/flex002/user_avatar/www.rubin.community/jrob93/32/4102_2.png) [@jrob93](https://www.rubin.community/u/jrob93)\
**Post date:** [February 10, 2026, 8:46pm UTC](https://www.rubin.community/t/rsp-dalqueryerror/11578/4 "2026-02-10T20:46:26Z")

</div>

Yes, I can confirm that things are working for me again, cheers!

---

<div class="post-metadata">

**Author:** ![jrob93](https://sea2.discourse-cdn.com/flex002/user_avatar/www.rubin.community/jrob93/32/4102_2.png) [@jrob93](https://www.rubin.community/u/jrob93)\
**Post date:** [February 11, 2026, 5:23pm UTC](https://www.rubin.community/t/rsp-dalqueryerror/11578/5 "2026-02-11T17:23:03Z")

</div>

Hi @MelissaGraham looks like the same problem cropped up again for me today (around 14:00 UTC). @solontoi also gets the same error (around 16:30 UTC) so I think it’s not just me!

```auto
 DALQueryError: Query Error: Query failed in backend: MERGE_ERROR 2010 (failed to open/read: http://sdfqserv004.sdf.slac.stanford.edu:39953/6-5774874-0-78967-0.csv, fileSize: 1027353, offset: 0, ex: error: 'Couldn't resolve host name', errnum: 6) 2026-02-11T16:31:47+0000

```

---

<div class="post-metadata">

**Author:** ![MelissaGraham](https://sea2.discourse-cdn.com/flex002/user_avatar/www.rubin.community/melissagraham/32/2549_2.png) [@MelissaGraham](https://www.rubin.community/u/MelissaGraham)\
**Post date:** [February 11, 2026, 7:19pm UTC](https://www.rubin.community/t/rsp-dalqueryerror/11578/6 "2026-02-11T19:19:42Z")

</div>

I can confirm that TAP queries are back up at data.lsst.cloud. It looks like the team caught this earlier today and implemented a fix. Please keep reporting issues as they come up thank you!

---

<div class="post-metadata">

**Author:** ![jrob93](https://sea2.discourse-cdn.com/flex002/user_avatar/www.rubin.community/jrob93/32/4102_2.png) [@jrob93](https://www.rubin.community/u/jrob93)\
**Post date:** [February 12, 2026, 10:03am UTC](https://www.rubin.community/t/rsp-dalqueryerror/11578/7 "2026-02-12T10:03:18Z")

</div>

Sure thing, queries are working again for me now

---

<div class="post-metadata">

**Author:** ![jrob93](https://sea2.discourse-cdn.com/flex002/user_avatar/www.rubin.community/jrob93/32/4102_2.png) [@jrob93](https://www.rubin.community/u/jrob93)\
**Post date:** [February 12, 2026, 11:00am UTC](https://www.rubin.community/t/rsp-dalqueryerror/11578/8 "2026-02-12T11:00:27Z")

</div>

Hhm, after a morning of working on some notebooks it’s back down again:

```auto
DALQueryError: Query Error: Qserv request failed: operation failed due to: MySqlConnection::getMySql connection is not open.

```

I see that [https://data.lsst.cloud/](https://data.lsst.cloud/) has had a red banner all today warning about service disruption so I guess this is ongoing and being actively looked at.

Update: as of 11:40 UTC my queries are running again, service must be intermittent.

---

<div class="post-metadata">

**Author:** ![MelissaGraham](https://sea2.discourse-cdn.com/flex002/user_avatar/www.rubin.community/melissagraham/32/2549_2.png) [@MelissaGraham](https://www.rubin.community/u/MelissaGraham)\
**Post date:** [February 12, 2026, 4:34pm UTC](https://www.rubin.community/t/rsp-dalqueryerror/11578/9 "2026-02-12T16:34:35Z")

</div>

Yes the red banner went up once the issue was found to be persistently intermittent (and the fixes temporary). The red banner will stay up until the fix is permanent. Thanks again for keeping up the reporting it’s really useful!
