# DM Weekly Highlights 2016-10-05 to 2016-10-11

**URL:** <https://www.rubin.community/t/dm-weekly-highlights-2016-10-05-to-2016-10-11/1228>\
**Category:** DM Notifications\
**Tags:** dm-highlights\
**Created:** [October 12, 2016, 6:12pm UTC](https://www.rubin.community/t/dm-weekly-highlights-2016-10-05-to-2016-10-11/1228 "2016-10-12T18:12:11Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![timj](https://sea2.discourse-cdn.com/flex002/user_avatar/www.rubin.community/timj/32/10_2.png) [@timj](https://www.rubin.community/u/timj)\
**Post date:** [October 12, 2016, 6:12pm UTC](https://www.rubin.community/t/dm-weekly-highlights-2016-10-05-to-2016-10-11/1228/1 "2016-10-12T18:12:11Z")

</div>

## Accomplishments

- [A major improvement to the handling of generic exposure metadata](http://www.rubin.community/t/unified-exposure-metadata/1214/6) was completed. Pipeline tasks no longer need to query FITS headers directly. ([DM-5503](https://jira.lsstcorp.org/browse/DM-5503))
- Following [RFC-230](https://jira.lsstcorp.org/browse/RFC-230), [`daf_butlerUtils` has been renamed to `obs_base`](http://www.rubin.community/t/daf-butlerutils-is-now-obs-base/1225/3). ([DM-7915](https://jira.lsstcorp.org/browse/DM-7915))
- Stripe82 co-adds are now available at the PDAC. ([DM-7748](https://jira.lsstcorp.org/browse/DM-7748))

## Documentation

- [I/O flow through L1 Prompt Processing](https://jira.lsstcorp.org/secure/attachment/28557/I_O%20flow%20through%20L1%20Prompt%20Processing-1.pdf) swim lane diagram. ([DM-7707](https://jira.lsstcorp.org/browse/DM-7707))
- Poster to be presented at ADASS XXVI next week: [Porting the LSST Data Management Pipeline Software to Python 3](http://doi.org/10.5281/zenodo.159973). ([DM-7864](https://jira.lsstcorp.org/browse/DM-7864))
- [Current orchestration internals](https://confluence.lsstcorp.org/display/DM/8.+Orchestration+Internals). ([DM-7868](https://jira.lsstcorp.org/browse/DM-7868))
- [http://www.rubin.community](http://www.rubin.community) now has [documented community guidelines](http://www.rubin.community/faq) including a code of conduct and disclaimer. ([DM-7845](https://jira.lsstcorp.org/browse/DM-7845))
- Following [a discussion](http://www.rubin.community/t/the-dangers-of-git-on-lsst-dev/1216), the developer guide was updated to have more discussion on the [use of force push of git branches](https://developer.lsst.io/tools/git_setup.html). ([DM-7919](https://jira.lsstcorp.org/browse/DM-7919))
- The [DR processing data flow diagram](https://confluence.lsstcorp.org/display/~hchiang2/DRP+Data+Flow) was updated. ([DM-7916](https://jira.lsstcorp.org/browse/DM-7916))

## RFC Activity

- [RFC-242](https://jira.lsstcorp.org/browse/RFC-242): **PROPOSED** Prefer parentheses (or nothing) to braces in C++ initialization.
- [RFC-230](https://jira.lsstcorp.org/browse/RFC-230): **ADOPTED** Rename `daf_butlerUtils` to `obs_base`.
- [RFC-228](https://jira.lsstcorp.org/browse/RFC-228): **WITHDRAWN** Renamed `obs_test` to `obs_example`.
- [RFC-187](https://jira.lsstcorp.org/browse/RFC-187): **IMPLEMENTED** Remove `DetectAndMeasureTask`.
- [RFC-143](https://jira.lsstcorp.org/browse/RFC-143): **IMPLEMENTED** Refactor aperture corrections and measurement afterburners.

## Other items

- A `--show history` option has been added to `cmdLineTask`. ([DM-5421](https://jira.lsstcorp.org/browse/DM-5421))
- `pybind11` progress continues to be made. ([DM-7519](https://jira.lsstcorp.org/browse/DM-7519))
- The enum constants for time system and scale in `daf_base.DateTime` have been changed such that they do not have the same values in Python. Before this MJD and UTC could be used interchangeably. ([DM-7745](https://jira.lsstcorp.org/browse/DM-7745))
