# DM Highlights 2016-04-20 to 2016-04-26

**URL:** <https://www.rubin.community/t/dm-highlights-2016-04-20-to-2016-04-26/727>\
**Category:** DM Notifications\
**Tags:** dm-highlights\
**Created:** [April 27, 2016, 9:36pm UTC](https://www.rubin.community/t/dm-highlights-2016-04-20-to-2016-04-26/727 "2016-04-27T21:36:32Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![timj](https://sea2.discourse-cdn.com/flex002/user_avatar/www.rubin.community/timj/32/10_2.png) [@timj](https://www.rubin.community/u/timj)\
**Post date:** [April 27, 2016, 9:36pm UTC](https://www.rubin.community/t/dm-highlights-2016-04-20-to-2016-04-26/727/1 "2016-04-27T21:36:32Z")

</div>

## Accomplishments

- Measurement afterburners in `meas_base` have been refactored into a new plugin system. ([DM-4887](https://jira.lsstcorp.org/browse/DM-4887))
- An investigation into Cython and `pybind11` as a replacement for SWIG has now completed with the conclusion that `pybind11` looks very promising. ([DM-5471](https://jira.lsstcorp.org/browse/DM-5471), [DM-5676](https://jira.lsstcorp.org/browse/DM-5676))
- `validate_drp` has been updated to use well-motivated theoretical fits to the astrometric and photometric performance measurements based on derivations from the [LSST Overview paper](http://arxiv.org/pdf/0805.2366v4.pdf). ([DM-5660](https://jira.lsstcorp.org/browse/DM-5660))

## Documentation

- [DMTN-007](http://dmtn-007.lsst.io): Dipole characterization for image differencing.
- [DMTN-008](http://dmtn-008.lsst.io): Introducing `validate_drp`: Calculate SRD Key Performance Metrics for an output repository.
- [DMTN-013](http://dmtn-013.lsst.io): Wrapping C++ with Cython.
- [DMTN-014](http://dmtn-014.lsst.io): Wrapping C++ with pybind11.

## RFC Activity

- [RFC-171](https://jira.lsstcorp.org/browse/RFC-171): **PROPOSED** Add `pipe_drivers` to `lsst_distrib`.
- [RFC-170](https://jira.lsstcorp.org/browse/RFC-170): **IMPLEMENTED** Add a 3rd Party package for Erin Sheldon’s `ngmix` GitHub repository.
- [RFC-169](https://jira.lsstcorp.org/browse/RFC-169): **ADOPTED** Implement HSC-like stack provenance.

## Other Items

- The `jointcal` package, a port of `meas_simastrom`, can now be built and is undergoing testing. ([DM-5133](https://jira.lsstcorp.org/browse/DM-5133))
- `meas_extensions_simpleShape` has been released. ([DM-5682](https://jira.lsstcorp.org/browse/DM-5682))
- A [new mapping has been written for the Starlink AST library](https://github.com/Starlink/ast/pull/1) that outputs a unit vector and norm relative to a specified center. This is part of the investigation into WCS libraries. ([DM-5702](https://jira.lsstcorp.org/browse/DM-5702))
- The `ngmix` Python package has been added as a third-party package. ([DM-2253](https://jira.lsstcorp.org/browse/DM-2253))
