# DM Notifications

**URL:** https://www.rubin.community/c/dm/dm-notifications/11.md

[Latest](https://www.rubin.community/latest.md) · [Categories](https://www.rubin.community/categories.md) · [Tags](https://www.rubin.community/tags.md)

---

## [About the DM Notifications category](https://www.rubin.community/t/about-the-dm-notifications-category/52)

<div class="topic-metadata">

**Author:** [@jsick](https://www.rubin.community/u/jsick)\
**Replies:** 0

</div>

Informal announcements related to DM and the Stack. Use this as a place to let other developers know about a ticket that was merged and adds cool features, fixes to longstanding bugs, new documentation, etc. Offic…

---

## [Deploying Rubin-env 13.1](https://www.rubin.community/t/deploying-rubin-env-13-1/12320)

<div class="topic-metadata">

**Author:** [@ross](https://www.rubin.community/u/ross)\
**Replies:** 0\
**Last updated:** [July 22, 2026, 2:12am UTC](https://www.rubin.community/t/deploying-rubin-env-13-1/12320 "2026-07-22T02:12:27Z")

</div>

We’re pleased to announce the release of rubin-env 13.1. Key highlights: Astropy upgraded to \>=8.0.1,\<9 (biggest change in this release) NumPy bumped to 2.4 libgdal-core added (3.13), with supporting bump of libpq to …

---

## [Changes to Synthetic Source Injection Dataset Naming Conventions](https://www.rubin.community/t/changes-to-synthetic-source-injection-dataset-naming-conventions/11970)

<div class="topic-metadata">

**Author:** [@lskelvin](https://www.rubin.community/u/lskelvin)\
**Replies:** 0\
**Last updated:** [May 12, 2026, 3:59pm UTC](https://www.rubin.community/t/changes-to-synthetic-source-injection-dataset-naming-conventions/11970 "2026-05-12T15:59:07Z")

</div>

On Jira ticket DM-53324, a change has been implemented in the LSST Science Pipelines that modifies the recommended dataset naming conventions we use as part of our synthetic source injection pipelines. Until now, all da…

---

## [Deploying Rubin-Env 13](https://www.rubin.community/t/deploying-rubin-env-13/11886)

<div class="topic-metadata">

**Author:** [@ross](https://www.rubin.community/u/ross)\
**Replies:** 0\
**Last updated:** [April 17, 2026, 5:42am UTC](https://www.rubin.community/t/deploying-rubin-env-13/11886 "2026-04-17T05:42:08Z")

</div>

Hello everyone, Today I come to inform you that we have a new rubin-env out for you to play with. Rubin env 13 focuses on security and updating some of the underlying infrastructure in our environment. Rubin env 13.0.0…

---

## [Advertisement of rust developer guidelines](https://www.rubin.community/t/advertisement-of-rust-developer-guidelines/11368)

<div class="topic-metadata">

**Author:** [@natelust](https://www.rubin.community/u/natelust)\
**Replies:** 0\
**Last updated:** [December 8, 2025, 9:55pm UTC](https://www.rubin.community/t/advertisement-of-rust-developer-guidelines/11368 "2025-12-08T21:55:37Z")

</div>

In RFC-1069 it was decided that the Rust programming language would be added as a development language for the science pipelines. The ground work for this is done, and a draft for the developer guide on using Rust for d…

---

## [Transitioning to eups.lsst.cloud on 11/12/2025](https://www.rubin.community/t/transitioning-to-eups-lsst-cloud-on-11-12-2025/11199)

<div class="topic-metadata">

**Author:** [@ross](https://www.rubin.community/u/ross)\
**Replies:** 0\
**Last updated:** [November 3, 2025, 6:26pm UTC](https://www.rubin.community/t/transitioning-to-eups-lsst-cloud-on-11-12-2025/11199 "2025-11-03T18:26:07Z")

</div>

As part of our ongoing efforts to improve our services, streamline our operations and move away from AWS, we have decided to permanently transition from eups.lsst.codes to eups.lsst.cloud next week. Over the past month,…

---

## [New PredictedQuantumGraph class and file format](https://www.rubin.community/t/new-predictedquantumgraph-class-and-file-format/11033)

<div class="topic-metadata">

**Author:** [@jbosch](https://www.rubin.community/u/jbosch)\
**Replies:** 1\
**Last updated:** [October 2, 2025, 2:42pm UTC](https://www.rubin.community/t/new-predictedquantumgraph-class-and-file-format/11033 "2025-10-02T14:42:58Z")

</div>

I’ve just merged (in time for d\_2025\_10\_01) DM-51850, which adds a new lsst.pipe.base.quantum\_graph.PredictedQuantumGraph class and corresponding file format, which will soon be fully replacing lsst.pipe.base.QuantumGrap…

---

## [Deploying Rubin env 11](https://www.rubin.community/t/deploying-rubin-env-11/10969)

<div class="topic-metadata">

**Author:** [@ross](https://www.rubin.community/u/ross)\
**Replies:** 0\
**Last updated:** [September 16, 2025, 6:21pm UTC](https://www.rubin.community/t/deploying-rubin-env-11/10969 "2025-09-16T18:21:56Z")

</div>

I am excited to announce that we are rolling out another significant upgrade to our build infrastructure. This week, we will transition to the rubin-env 11.0.0 conda-forge metapackage. We will be rolling this out today (…

---

## [Ctrl\_bps\_htcondor will combine job's stderr and stdout](https://www.rubin.community/t/ctrl-bps-htcondor-will-combine-jobs-stderr-and-stdout/10943)

<div class="topic-metadata">

**Author:** [@mxk](https://www.rubin.community/u/mxk)\
**Replies:** 0\
**Last updated:** [September 11, 2025, 6:06pm UTC](https://www.rubin.community/t/ctrl-bps-htcondor-will-combine-jobs-stderr-and-stdout/10943 "2025-09-11T18:06:50Z")

</div>

Once DM-31879 is merged, BPS HTCondor plugin ( ctrl\_bps\_htcondor) will start redirecting both job’s stdout and stderr to the same file (\<job name\>.out). In other words, BPS submissions using ctrl\_bps\_htcondor will no lo…

---

## [Third-party metadetect included as part of lsst\_distrib](https://www.rubin.community/t/third-party-metadetect-included-as-part-of-lsst-distrib/10806)

<div class="topic-metadata">

**Author:** [@arunkannawadi](https://www.rubin.community/u/arunkannawadi)\
**Replies:** 0\
**Last updated:** [August 13, 2025, 3:44pm UTC](https://www.rubin.community/t/third-party-metadetect-included-as-part-of-lsst-distrib/10806 "2025-08-13T15:44:11Z")

</div>

I just merged DM-52110 which distributes a DM-maintained fork of the third-party metadetect as part of lsst\_distrib (as a dependency of drp\_tasks) as discussed in RFC-1100. This would be available by default when setting…

---

## [Deploying rubin-env 10.1.0](https://www.rubin.community/t/deploying-rubin-env-10-1-0/10763)

<div class="topic-metadata">

**Author:** [@mwittgen](https://www.rubin.community/u/mwittgen)\
**Replies:** 0\
**Last updated:** [August 5, 2025, 10:40pm UTC](https://www.rubin.community/t/deploying-rubin-env-10-1-0/10763 "2025-08-05T22:40:25Z")

</div>

The minor version update rubin-env 10.1.0 will be deployed effective with the following releases: Weekly: w\_2025\_32 Daily: d\_2025\_08\_06 Change: pybind11 has been updated from version 2 to version 3. While vers…

---

## [Pipeline execution code moved to pipe\_base](https://www.rubin.community/t/pipeline-execution-code-moved-to-pipe-base/10721)

<div class="topic-metadata">

**Author:** [@jbosch](https://www.rubin.community/u/jbosch)\
**Replies:** 0\
**Last updated:** [July 29, 2025, 10:24pm UTC](https://www.rubin.community/t/pipeline-execution-code-moved-to-pipe-base/10721 "2025-07-29T22:24:28Z")

</div>

I’ve just merged DM-48980, which implements the deprecation phase of RFC-1066 by moving a lot of code from ctrl\_mpexec to pipe\_base (with shims for backwards compatibility that emit deprecation warnings when imported or …

---

## [HEALPix and arbitrary HTM orders now supported in QuantumGraph builds](https://www.rubin.community/t/healpix-and-arbitrary-htm-orders-now-supported-in-quantumgraph-builds/10543)

<div class="topic-metadata">

**Author:** [@jbosch](https://www.rubin.community/u/jbosch)\
**Replies:** 0\
**Last updated:** [July 9, 2025, 3:03pm UTC](https://www.rubin.community/t/healpix-and-arbitrary-htm-orders-now-supported-in-quantumgraph-builds/10543 "2025-07-09T15:03:53Z")

</div>

I’ve just merged DM-51176, which gives the general-purpose quantum graph builder used by pipetask nearly complete support for fixed HEALPix and HTM dimensions. PipelineTask authors are now free to use dimensions like he…

---

## [Upcoming camera geometry parity flip for LATISS and DECam](https://www.rubin.community/t/upcoming-camera-geometry-parity-flip-for-latiss-and-decam/10198)

<div class="topic-metadata">

**Author:** [@jbosch](https://www.rubin.community/u/jbosch)\
**Replies:** 1\
**Last updated:** [June 16, 2025, 7:31pm UTC](https://www.rubin.community/t/upcoming-camera-geometry-parity-flip-for-latiss-and-decam/10198 "2025-06-16T19:31:03Z")

</div>

I’m starting in on implementing RFC-605, which has been adopted but dormant for five years. This will redefine the FIELD\_ANGLE coordinate system for LATISS and DECam by flipping the x-axis relative to the FOCAL\_PLANE co…

---

## [Transitioning to ghcr as OCI repository](https://www.rubin.community/t/transitioning-to-ghcr-as-oci-repository/9908)

<div class="topic-metadata">

**Author:** [@ross](https://www.rubin.community/u/ross)\
**Replies:** 1\
**Last updated:** [May 14, 2025, 8:52pm UTC](https://www.rubin.community/t/transitioning-to-ghcr-as-oci-repository/9908 "2025-05-14T20:52:25Z")

</div>

Starting today, our Docker images will be officially hosted on GitHub Container Registry (ghcr.io) rather than Docker Hub. This change includes updates to both the repository path and tag format. We will maintain updates…

---

## [Speeding up builds in lsstsw and Jenkins/GitHub PR integration](https://www.rubin.community/t/speeding-up-builds-in-lsstsw-and-jenkins-github-pr-integration/10051)

<div class="topic-metadata">

**Author:** [@ross](https://www.rubin.community/u/ross)\
**Replies:** 2\
**Last updated:** [May 11, 2025, 1:43am UTC](https://www.rubin.community/t/speeding-up-builds-in-lsstsw-and-jenkins-github-pr-integration/10051 "2025-05-11T01:43:29Z")

</div>

Hello community, I am happy to announce that we have 2 new features. We just released a new version of lsstsw. This new version will allow for our testing environments to download prebuilt binaries instead of building…

---

## [Data ID tables and task expressions in Quantum Graph builds](https://www.rubin.community/t/data-id-tables-and-task-expressions-in-quantum-graph-builds/9993)

<div class="topic-metadata">

**Author:** [@jbosch](https://www.rubin.community/u/jbosch)\
**Replies:** 0\
**Last updated:** [April 16, 2025, 3:16pm UTC](https://www.rubin.community/t/data-id-tables-and-task-expressions-in-quantum-graph-builds/9993 "2025-04-16T15:16:32Z")

</div>

I’d happy to announce the availability of two bits of long-promised pipeline functionality (since the weekend, actually, but some docs are only landing in today’s d\_2025\_04\_16): You can now pass --data-id-table \<filen…

---

## [Important Package Changes since rubin-env 10.0.0](https://www.rubin.community/t/important-package-changes-since-rubin-env-10-0-0/9949)

<div class="topic-metadata">

**Author:** [@ross](https://www.rubin.community/u/ross)\
**Replies:** 1\
**Last updated:** [April 1, 2025, 2:30am UTC](https://www.rubin.community/t/important-package-changes-since-rubin-env-10-0-0/9949 "2025-04-01T02:30:11Z")

</div>

We want to inform you about several important package updates and additions to the Rubin Environment since the initial release of rubin-env 10.0.0: Updates: ngmix-core: Pinned to \>=2.4.0 to resolve numpy 2 compatibili…

---

## [Changes to LSST pipelines binary distribution](https://www.rubin.community/t/changes-to-lsst-pipelines-binary-distribution/9823)

<div class="topic-metadata">

**Author:** [@ross](https://www.rubin.community/u/ross)\
**Replies:** 3\
**Last updated:** [March 5, 2025, 7:03pm UTC](https://www.rubin.community/t/changes-to-lsst-pipelines-binary-distribution/9823 "2025-03-05T19:03:25Z")

</div>

We’re excited to share some significant updates regarding our software build platform in Jenkins. Starting w\_2025\_05 we will be supporting executables for Linux aarch64 and Apple silicon chips. We have successfully expa…

---

## [Deploying rubin-env 10.0.0](https://www.rubin.community/t/deploying-rubin-env-10-0-0/9845)

<div class="topic-metadata">

**Author:** [@ross](https://www.rubin.community/u/ross)\
**Replies:** 0\
**Last updated:** [February 19, 2025, 1:00am UTC](https://www.rubin.community/t/deploying-rubin-env-10-0-0/9845 "2025-02-19T01:00:39Z")

</div>

I am pleased to announce that we are implementing a significant upgrade to our build infrastructure. Effective this week, we will transition to the rubin-env 10.0.0 conda-forge metapackage. This update will be reflected …

---

## [Many Parquet datasets now default to Astropy instead of Pandas](https://www.rubin.community/t/many-parquet-datasets-now-default-to-astropy-instead-of-pandas/9780)

<div class="topic-metadata">

**Author:** [@jbosch](https://www.rubin.community/u/jbosch)\
**Replies:** 1\
**Last updated:** [January 28, 2025, 4:19pm UTC](https://www.rubin.community/t/many-parquet-datasets-now-default-to-astropy-instead-of-pandas/9780 "2025-01-28T16:19:50Z")

</div>

Last night I merged DM-34875, which changes the butler “storage class” for many (but not all) of our Parquet datasets (including objectTable\[\_tract\] and sourceTable\[\_visit\]) from pandas.DataFrame to astropy.table.Table. …

---

## [Changes to SCons Package Metadata for LSST Pipelines packages](https://www.rubin.community/t/changes-to-scons-package-metadata-for-lsst-pipelines-packages/9678)

<div class="topic-metadata">

**Author:** [@timj](https://www.rubin.community/u/timj)\
**Replies:** 2\
**Last updated:** [January 16, 2025, 3:30pm UTC](https://www.rubin.community/t/changes-to-scons-package-metadata-for-lsst-pipelines-packages/9678 "2025-01-16T15:30:59Z")

</div>

Over the winter break I have modified package installation with SCons (specifically sconsUtils) such that the science pipelines packages now conform to Python packaging metadata standards. As of w\_2025\_01 package versio…

---

## [Metadata translator command-line updates](https://www.rubin.community/t/metadata-translator-command-line-updates/9707)

<div class="topic-metadata">

**Author:** [@timj](https://www.rubin.community/u/timj)\
**Replies:** 0\
**Last updated:** [January 13, 2025, 9:18pm UTC](https://www.rubin.community/t/metadata-translator-command-line-updates/9707 "2025-01-13T21:18:47Z")

</div>

I just merged a change to the metadata translation command line which should make things a little easier. Previously, when you wanted to translate an LSSTCam header you would have to say: $ astrometadata -p lsst.obs.ls…

---

## [BPS stops supporting the execution butler](https://www.rubin.community/t/bps-stops-supporting-the-execution-butler/9432)

<div class="topic-metadata">

**Author:** [@mxk](https://www.rubin.community/u/mxk)\
**Replies:** 0\
**Last updated:** [October 1, 2024, 7:48pm UTC](https://www.rubin.community/t/bps-stops-supporting-the-execution-butler/9432 "2024-10-01T19:48:18Z")

</div>

Quantum-backed butler is now de facto standard LSST mechanism to for reducing access to the central butler registry when running LSST pipelines at scale. As a result, the support for its predecessor, the execution butler…

---

## [New Butler query system released](https://www.rubin.community/t/new-butler-query-system-released/9364)

<div class="topic-metadata">

**Author:** [@timj](https://www.rubin.community/u/timj)\
**Replies:** 0\
**Last updated:** [September 6, 2024, 8:39pm UTC](https://www.rubin.community/t/new-butler-query-system-released/9364 "2024-09-06T20:39:57Z")

</div>

\[This functionality is available on the Rubin Science Platform from Weekly 2024\_37 onwards\] Today I merged ticket DM-45872 which moves the new query system APIs from experimental mode to fully public mode. We have also …

---

## [Changes to default handing of \`AnnotatedPartialOutputsError\`](https://www.rubin.community/t/changes-to-default-handing-of-annotatedpartialoutputserror/9020)

<div class="topic-metadata">

**Author:** [@jbosch](https://www.rubin.community/u/jbosch)\
**Replies:** 1\
**Last updated:** [August 28, 2024, 5:06pm UTC](https://www.rubin.community/t/changes-to-default-handing-of-annotatedpartialoutputserror/9020 "2024-08-28T17:06:29Z")

</div>

I’ve just merged DM-44488, which belatedly finishes off the implementation of RFC-958 by introducing special handling for the new lsst.pipe.base.AnnotatedPartialOutputsError exception: by default, when this exception i…

---

## [Deploying rubin-env 9.0.0](https://www.rubin.community/t/deploying-rubin-env-9-0-0/8942)

<div class="topic-metadata">

**Author:** [@ktl](https://www.rubin.community/u/ktl)\
**Replies:** 6\
**Last updated:** [August 5, 2024, 6:45pm UTC](https://www.rubin.community/t/deploying-rubin-env-9-0-0/8942 "2024-08-05T18:45:24Z")

</div>

On Friday, 2024-08-02, we updated our build infrastructure to use version 9.0.0 of the rubin-env conda-forge metapackage. The d\_2024\_08\_03 daily and w\_2024\_32 weekly will be the first tagged releases to incorporate this …

---

## [Removing DimensionGraph and DataCoordinate's Mapping interface](https://www.rubin.community/t/removing-dimensiongraph-and-datacoordinates-mapping-interface/8908)

<div class="topic-metadata">

**Author:** [@jbosch](https://www.rubin.community/u/jbosch)\
**Replies:** 0\
**Last updated:** [July 24, 2024, 2:29pm UTC](https://www.rubin.community/t/removing-dimensiongraph-and-datacoordinates-mapping-interface/8908 "2024-07-24T14:29:36Z")

</div>

Later today I’m planning to merge DM-41326, which completes the implementation of RFC-834 by removing a number of already-deprecated middleware interfaces, including the DimensionGraph class (replaced by DimensionGroup) …

---

## [Rolling updates to coaddition tasks](https://www.rubin.community/t/rolling-updates-to-coaddition-tasks/8775)

<div class="topic-metadata">

**Author:** [@arunkannawadi](https://www.rubin.community/u/arunkannawadi)\
**Replies:** 0\
**Last updated:** [June 25, 2024, 8:13pm UTC](https://www.rubin.community/t/rolling-updates-to-coaddition-tasks/8775 "2024-06-25T20:13:37Z")

</div>

In the coming weeks, there’d be some significant additions and improvements related to the image coaddition part of the DRP pipeline as we march towards producing cell-based coadds. Most of them are expected to be transp…

---

## [Upcoming config change to AP Pipelines](https://www.rubin.community/t/upcoming-config-change-to-ap-pipelines/8543)

<div class="topic-metadata">

**Author:** [@kfindeisen](https://www.rubin.community/u/kfindeisen)\
**Replies:** 0\
**Last updated:** [April 30, 2024, 7:17pm UTC](https://www.rubin.community/t/upcoming-config-change-to-ap-pipelines/8543 "2024-04-30T19:17:33Z")

</div>

With the merging of DM-43416 later today, ApPipe.yaml and all related pipelines will use the new APDB configuration system developed by @andy\_slac . The system will make it easier to support Cassandra databases (coming v…

[Next page](https://www.rubin.community/c/dm/dm-notifications/11.md?page=1)
